Taki błąd może się pojawić np. po instalacji modułu DPD.

Np. przy wejściu na strony:

  • lista modułów w adminie
  • rejestracja klientów sklepu

Błąd jest domyślnie ukryty (pojawia się biała strona) i dopiero po włączeniu pokazywania błędów w pliku:


/config/defines.inc.php

Pojawia się „bardzo jasny” błąd:


[PrestaShop] Fatal error in module controller:
syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM

Ewentulanie:


Fatal error in module controller: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM

Co zrobić w tej sytuacji?

Można odinstalować w/w moduł DPD. Jednak za błąd odpowiedzialna jest prawdopodobnie wersja PHP na Twoim serwerze.

Jaką posiadasz możesz ją sprawdzić w zapleczu Twojego sklepu:

Parametry zaawansowane >> Informacje konfiguracyjne

U nas błąd pojawiał się dla wersji:

Wersja PHP 5.2.17

Po zaktualizowaniu PHP do wersji:

Wersja PHP 5.5.24

lub:

Wersja PHP 5.5.9-1ubuntu4.9

Błąd już nie występuje.

Share This:

Zostaw komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *